We are seeing a steady decrease of failed bounces with a "554 Transaction failed” error. This indicates Microsoft has mitigated the issue. The majority of these bounces were classified as blocks, but double check your bounce suppression list and delete any of these bounces before resending. Please refer to Microsoft’s status page for further updates: https://portal.office.com/servicestatus.
Posted May 12, 2016 - 13:22 PDT
Monitoring
The bounces appear to be related to a broader issue that Microsoft is currently investigating. Until they identify the cause, you may continue to see bounces to Microsoft domains. We'll continue to monitor the situation.
Posted May 12, 2016 - 09:01 PDT
Investigating
We are currently investigating an issue according to which Microsoft bounces some of our emails with a "554 Transaction failed" error. Our engineers are looking into this. Updates to follow.