Technical Incident: Email Delays
Incident Report for SendGrid
Resolved
Our operations team has resolved this incident and mail is processing as expected. Any mail that was delayed has been processed as well. We apologize for any inconvenience this caused. Please contact our support team with questions at https://support.sendgrid.com/.
Posted Jan 03, 2017 - 16:23 PST
Identified
We're currently in the process of mitigating mail that has been queued up due to this technical incident. All new mail is processing immediately.

We'll provide additional updates once our queues normalize.
Posted Jan 03, 2017 - 15:03 PST
Investigating
Our operations team is investigating reports of mail delays. We apologize for any inconvenience this has caused. Updates to follow.
Posted Jan 03, 2017 - 13:20 PST
This incident affected: Marketing Campaigns (Marketing Campaigns) and Mail Sending (API v3, SMTP, API v2).