Technical Incident: Deferrals due to MX Record Look Up
Incident Report for SendGrid
Resolved
We have mitigated the MX look up issue causing these deferrals, and will begin to see a decrease in deferrals and bounces with the "Unable to resolve MX record" reason.

We apologize for any inconvenience this may have caused. Please contact our Support team with questions at https://support.sendgrid.com/.
Posted about 2 months ago. Mar 31, 2017 - 01:50 PDT
Investigating
We are currently seeing increased reports of bounces and deferrals due to unresolved MX record look ups for .au domains. Our team is investigating the cause and we will update with more information as it becomes available. Please reach out to our support team at https://support.sendgrid.com with any questions.
Posted about 2 months ago. Mar 31, 2017 - 00:32 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).