Paid Signup, Upgrade, and Billing Issues
Incident Report for SendGrid
Resolved
We've monitored the restored services and are confident paid sign ups and upgrades are fully operational. If you were unable to upgrade or have created a free account during this downtime, you will now be able to upgrade to the paid plan of your choice. We apologize for any inconvenience this caused. Please reach out to our Support Team at https://support.sendgrid.com with any questions.
Posted about 1 month ago. Nov 03, 2017 - 20:06 PDT
Monitoring
Our third-party billing provider has put a resolution in place. We'll continue monitoring performance to ensure the fix was successful. Please reach out to our Support Team at https://support.sendgrid.com/ with any questions.
Posted about 1 month ago. Nov 03, 2017 - 18:40 PDT
Investigating
Our third-party billing provider is currently experiencing a service disruption. Users attempting to sign up for paid accounts, upgrade their accounts, update their credit cards, or preview invoices may encounter errors. We'll continue to follow the investigation and provide updates. Please reach out to our Support Team at https://support.sendgrid.com/ with any questions.
Posted about 1 month ago. Nov 03, 2017 - 17:05 PDT