Coupons for new sign-ups not being applied
Incident Report for SendGrid
Resolved
With the release of the new site, we've deprecated the Coupon feature at this time.
Posted Jul 08, 2015 - 09:04 PDT
Identified
Currently our coupons for new sign ups aren't being applied. We have identified the issue and our Devs are fiercely working on a resolution. We do apologize for any hassle that has been created. Please contact support@sendgrid.com if you have signed up with a coupon and receive an incorrect invoice. Thanks! - AE
Posted Apr 10, 2015 - 08:48 PDT