High latency for East Coast US
Incident Report for SendGrid
Resolved
Our hosting provider has restored power at our east coast data center. We have been monitoring performance for the last few hours. All systems are back and fully functioning as expected.
Posted Jul 20, 2015 - 09:22 PDT
Monitoring
Power has been restored, we are currently monitoring some network issues. We will update you further when everything is back to normal.
Posted Jul 20, 2015 - 06:19 PDT
Identified
Our hosting provider has lost power at their east coast datacenter. Clients near the east coast of the US will be experiencing higher than normal latency when sending email to our servers.
More details to follow.
Posted Jul 20, 2015 - 05:51 PDT