Service Disruption: "Email Activity" feed delays
Incident Report for SendGrid
Resolved
We have completed posting delayed events to Email Activity. No events were lost. We apologize for any inconvenience this may have caused. Thank you for your patience. Please reach out to https://support.sendgrid.com if you have any questions.
Posted 26 days ago. Sep 27, 2017 - 09:13 PDT
Monitoring
Our team has identified the cause behind the event delay posts in Email Activity and have implemented a fix. We are currently monitoring the queued events as they post to Email Activity feeds and will provide an update when all of the delayed events have been posted. Thank you so much for your patience. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted 26 days ago. Sep 26, 2017 - 15:11 PDT
Identified
We are currently monitoring the queued events as they post to Email Activity feeds and will provide an update when we have additional information. Thank you so much for your patience. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted 26 days ago. Sep 26, 2017 - 14:19 PDT
Update
Our team is continuing to work on this with the utmost priority. Affected customers will see individual event posts such as "processed" or "delivered" delayed for up to 24 hours in the Email Activity page, or event posts potentially duplicated within that time frame. The events themselves are not delayed or duplicated, it's only in the posting of these events to Email Activity that is impacted. We apologize for any inconvenience this may cause. Please reach out to our Support team with any questions at https://support.sendgrid.com
Posted 26 days ago. Sep 26, 2017 - 12:56 PDT
Investigating
Our team is currently investigating reports of Email Activity feed delays. Mail is currently flowing as expected and our Event Webhook is not impacted by these delays. We will provide more information as we have it. Thank you for your patience and please reach out to our Support team with any questions at https://support.sendgrid.com.
Posted 26 days ago. Sep 26, 2017 - 12:03 PDT
This incident affected: Website.