Site down for customers using Amazon West/East
Incident Report for SendGrid
Resolved
It appears that Amazon has resolved the outage on their end.
If you continue to see issues and you believe it is related to this outage please contact us at support@sendgrid.com - AI
Posted Jun 30, 2015 - 21:08 PDT
Update
Our Ops team has confirmed that SendGrid mail flow has not and should not be affected by the outage in Amazon. However, the Amazon outage may affect site, and customers using Amazon West/East to send mail to SendGrid may see mail flow issues if the outage at Amazon is still occurring. - AI
Posted Jun 30, 2015 - 18:37 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2015 - 18:27 PDT
Identified
Our site went down due to the outage at Amazon West and East. This means that customers using Amazon West and East will be seeing issues until the outage at Amazon is resolved. Currently it looks like at no point did mail flow go down, but our Ops team is still investigating this to be sure. We apologize greatly for the inconveniences this has caused. Please contact support@sendgrid.com if you have any further questions or concerns. We will be monitoring the Amazon outage status and updating you here.

If you would like to keep watch on the status of Amazon, you can view their status page here http://status.aws.amazon.com/

- AI
Posted Jun 30, 2015 - 18:20 PDT