Technical Incident: Mail Delays
Incident Report for SendGrid
Resolved
Our team has monitored the solution put in place and are confident in it's efficacy. We apologize for any inconvenience and thank you for your patience. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted 9 days ago. Sep 11, 2017 - 13:18 PDT
Monitoring
Our team was able to locate and mitigate the issue causing mail delays for a subset of our customers. We have confirmed that all mail has been dequeued and traffic is flowing again without issue. We apologize for any inconvenience this may have caused, and thank you so much for your patience. Please reach out to our support team with any additional questions: https://support.sendgrid.com.
Posted 9 days ago. Sep 11, 2017 - 12:24 PDT
Investigating
We are currently investigating reports of delayed mail for a subset of our customers. Our Operations team is looking into this with the highest priority. We will provide an update when we have more information available, thank you for your patience. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted 9 days ago. Sep 11, 2017 - 11:10 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).