Technical Incident: Email Delays
Incident Report for SendGrid
Resolved
Our Ops team has been monitoring performance throughout the morning. Performance is stable and mail is flowing at a normal rate. We apologize for any inconvenience this may have caused.
Posted about 2 months ago. Apr 04, 2017 - 09:26 PDT
Update
We're closely monitoring performance of email traffic. New mail continues to be processed and delivered at a normal rate.

We sincerely apologize for any issues experienced, and will provide a final update once all delayed mail has been dequeued.
Posted about 2 months ago. Apr 04, 2017 - 05:53 PDT
Monitoring
Mail flow is rapidly dequeueing. Delayed mail is being processed, and new incoming mail should not be delayed. We're still monitoring, and will resolve once queues are maintaining at a normal level.
Posted about 2 months ago. Apr 04, 2017 - 04:27 PDT
Identified
We've identified and corrected the issue. Mail is currently dequeueing, so delays are still processing. We will update once the queues are back to normal.
Posted about 2 months ago. Apr 04, 2017 - 03:56 PDT
Investigating
We are currently investigating reports of emails being stuck in processed status. We have our Operations team looking at this with the highest priority. More information available here soon. Please contact our support team with any questions: https://support.sendgrid.com/hc/en-us.
Posted about 2 months ago. Apr 04, 2017 - 03:35 PDT