Support Live Chat Currently Offline
Incident Report for SendGrid
Resolved
The live chat support channel has been restored. Thanks for your patience. https://support.sendgrid.com
Posted Aug 28, 2015 - 16:33 PDT
Identified
Currently the option to live chat with our Support team is unavailable. However, our self help resources and our amazing Support staff are still here to help. Visit our help site to find answers and to contact our team directly: https://support.sendgrid.com

We're working to restore the live chat option asap. Thank you for your patience.
Posted Aug 28, 2015 - 08:54 PDT