Service Disruption - 3rd Party Billing Provider Unavailable
Incident Report for SendGrid
Resolved
Our vendor confirmed the issue is resolved. We apologize for any inconvenience this caused you. Please contact our support team with any questions: https://support.sendgrid.com/. -jz
Posted Jun 14, 2016 - 12:23 PDT
Monitoring
Our vendor reports they are monitoring a fix for their issue. Paid signup and upgrade functionally has returned but we'll continue to monitor performance until we get confirmation of the resolution. -jz
Posted Jun 14, 2016 - 11:37 PDT
Identified
Our 3rd party billing provider is intermittently unavailable. Invoices are currently inaccessible, and you may be unable to change plans until this is resolved.

Paid signups may see an error stating that only a free account was created. This account can be upgraded to a paid account once the 3rd party billing services restore. - RC
Posted Jun 14, 2016 - 09:52 PDT