Technical Incident - Marketing Campaigns Stats delays
Incident Report for SendGrid
Resolved
Our operations team resolved the issue and Marketing Campaigns stats are caught up. We apologize for any inconvenience this caused you. Please let our support team know if you have any questions: https://support.sendgrid.com/hc/en-us. -jz
Posted May 16, 2016 - 12:32 PDT
Investigating
We are investigating reports of stat delays in Marketing Campaigns. Campaign creation and sending are not impacted. More updates to follow. -jz
Posted May 16, 2016 - 12:08 PDT