Technical Incident: Email Delays
Incident Report for SendGrid
Resolved
We're declaring this technical incident resolved. Messages that were previously delayed have been processed.

Again, we apologize for any issues experienced. Please contact our support team if you have any questions: https://support.sendgrid.com.
Posted Nov 22, 2016 - 11:30 PST
Monitoring
We're closely monitoring performance of delayed mail traffic. New mail is being processed at a normal rate.

We sincerely apologize for any issues experienced, and will provide a final update once all delayed mail has dequeued.
Posted Nov 22, 2016 - 08:24 PST
Identified
We've identified a subset of mail traffic being delayed, and are currently in the process of mitigating the issue. Additional updates to follow.
Posted Nov 22, 2016 - 07:44 PST
This incident affected: Marketing Campaigns (Marketing Campaigns) and Mail Sending (API v3, SMTP, API v2).