Technical Incident: Email Delays
Incident Report for SendGrid
Resolved
We're declaring this technical incident resolved. Any messages that were delayed have been processed.

We sincerely apologize for any issues experienced. Please contact our support team if you have any questions: https://support.sendgrid.com.
Posted Oct 31, 2016 - 10:43 PDT
Monitoring
Our Operations team has mitigated the issue, and are currently monitoring performance. We’ll provide a final update once this issue is resolved.
Posted Oct 31, 2016 - 09:12 PDT
Identified
Our Operations team has identified a subset of mail traffic being delayed. They're currently working to mitigate this issue. Updates to follow.
Posted Oct 31, 2016 - 07:58 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns) and Mail Sending (API v3, SMTP, API v2).