Email Delays
Incident Report for SendGrid
Resolved
This incident has been resolved.
Posted Nov 23, 2015 - 15:00 PST
Monitoring
All email delays are resolved. We're continuing to monitor, but expect no further delays.
Posted Nov 23, 2015 - 12:15 PST
Identified
We've identified and resolved a major part of the email delays issue. You should no longer see `Connection Timed Out`-type Deferred events.
We're still investigating delayed delivered that have a Processed event with no Deferred event for an inordinate amount of time.
Posted Nov 23, 2015 - 11:59 PST
Update
We are still investigating reports of emails not being delivered after being processed at our end. We're also continuing to investigate deferred emails with the following failure reasons : "Connection timed out" , "Protocol error" and "Connection lost".
Posted Nov 23, 2015 - 06:40 PST
Monitoring
Our Operations team has identified the root cause of this issue and has deployed a fix. We will continue to monitor the email flow.
Posted Nov 23, 2015 - 05:41 PST
Investigating
We are currently investigating reports of email delays affecting some customers. We are at this with the highest priority, and we will update shortly with more information on a resolution. We apologize for any inconvenience this may cause.
Posted Nov 23, 2015 - 02:59 PST