Technical Incident: Mail Delay
Incident Report for SendGrid
Resolved
Our Operations team has confirmed that delays are resolved and mail has dequeued. Again, we apologize for any inconvenience these temporary delays may have caused and greatly appreciate your patience. Please reach out to the SendGrid Support team at https://support.sendgrid.com if you have any questions.
Posted about 1 month ago. Jul 17, 2018 - 13:26 PDT
Monitoring
A subset of our customers may have experienced a delay in mail sending beginning at approximately 1:00PM MST and lasting 30 minutes. Our Operations team is monitoring this delay as mail dequeues. We sincerely apologize for any inconvenience this may have caused. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted about 1 month ago. Jul 17, 2018 - 13:06 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).