Technical Incident: Stats Discrepancy
Incident Report for SendGrid
Resolved
Our team was able to correct the stats discrepancies for March 29 and 30. A small subset of users will still see a discrepancy for the stats from March 28 within the Stats pages on our site. All stats beyond March 30 contain no further discrepancies. As stated previously, we rectified all of the requests counts for our Billing Team before billing commenced on April 1. Please reach out to our support team with additional questions at https://support.sendgrid.com.
Posted about 2 months ago. Apr 06, 2017 - 16:18 PDT
Update
Our engineering team has ensured that stats that appear on April 1 invoices will be correct. The inaccurately inflated stats present in the UI for March 28 and 29 will not be a factor as we bill for usage incurred during March. We're continuing to work on correcting the stats reflected in the UI. Thank you for your patience.
Posted about 2 months ago. Mar 31, 2017 - 10:16 PDT
Identified
Our engineering team is continuing to work on the statistics discrepancies from March 28th through today. We will post an update when we have the statistics corrected. Thank you for your patience.
Posted about 2 months ago. Mar 30, 2017 - 19:55 PDT
Investigating
We are currently investigating reports of discrepancies in regards to reported statistics beginning on March 28th. They may appear to be inaccurately inflated in comparison to actual mail sent. We will update as we gather more information, please reach out to our Support Team at http://support.sendgrid.com with any questions.
Posted about 2 months ago. Mar 30, 2017 - 15:08 PDT
This incident affected: Website.