Technical Incident: Mail Delays
Incident Report for SendGrid
Resolved
Our team was able to locate and mitigate the issue causing mail delays for a small subset of customers. We have confirmed that all mail has been dequeued and traffic is flowing again without issue. We apologize for any inconvenience this may have caused, and thank you so much for your patience. Please reach out to our support team with any additional questions: https://support.sendgrid.com.
Posted 4 months ago. Aug 17, 2017 - 09:46 PDT
Identified
We are currently investigating reports of delayed mail. Our Operations team is looking into this with the highest priority. We will provide an update when we have more information available, thank you for your patience.

We experienced temporary availability for site login, Legacy Newsletter, Marketing Campaigns, and Transactional Template applications. These issues have been resolved at this time.

We apologize for any inconvenience this has caused. Please contact our support team with any questions: https://support.sendgrid.com
Posted 4 months ago. Aug 17, 2017 - 08:51 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2), Marketing Campaigns (Marketing Campaigns, Legacy Newsletter), and Website.