Delays with Legacy Newsletter
Incident Report for SendGrid
Resolved
We identified the issue causing the upload delays and have implemented a fix. Any campaigns that were in the queue have sent and uploading new contact lists has resumed normalcy. Going forward both Legacy Newsletter functions will operate normally. We apologize for any inconvenience this may have caused and if you have any questions please contact support. CP
Posted Nov 15, 2015 - 14:59 PST
Investigating
We are currently investigating some reports of delays in regards to Legacy Newsletter. We have reports that when uploading new contacts, the verification page does not fully load and thus the contacts are not uploaded. We are also seeing campaigns remain "in progress" status longer than normal, we are investigating the delay. We will post updates as they are available. CP
Posted Nov 15, 2015 - 14:05 PST