Technical Incident: Paid Signup and Upgrade issues
Incident Report for SendGrid
Resolved
The issue with our payment gateway has been resolved. Account upgrades and paid signups are restored. If you signed up for a free 40k trial account during this time, you will now be able to upgrade. If you encountered an error when trying to upgrade, add, or update payment information, please try again now. Thank you for your patience and please reach out to our Support Team at https://support.sendgrid.com/ with any questions.
Posted 3 months ago. Feb 24, 2017 - 12:06 PST
Identified
We are currently mitigating an issue with our payment gateway. Users attempting to sign up for paid accounts or upgrade may encounter errors.

In the interim if you are trying to sign up for a paid account, please sign up for a free 40k trial account. Once this is resolved, you will be able to immediately upgrade to the proper package. We apologize for the inconvenience. More updates to follow.
Posted 3 months ago. Feb 24, 2017 - 10:43 PST
This incident affected: Website.