Technical Incident: Delayed Mail
Incident Report for SendGrid
Resolved
After closely monitoring mail flow, we have determined that the current technical incident is now resolved. Messages that were previously delayed have been processed. We sincerely apologize and thank you for your patience. Please contact our support team if you have any questions: https://support.sendgrid.com.
Posted 3 months ago. Feb 09, 2017 - 17:03 PST
Monitoring
We have identified the root cause resulting in mail delays for a small subset of customers. We will continue to monitor mail flow as the delayed mail is being sent to ensure the interruption is resolved. We thank you for your patience and will provide a final update and information once available. Please visit status.sendgrid.com to subscribe to updates on this service interruption.
Posted 3 months ago. Feb 09, 2017 - 16:15 PST
Update
We are continuing to investigate reports of a small portion of customers experiencing mail delays. We will provide more updates and information as it becomes available. Please visit status.sendgrid.com to subscribe to updates.
Posted 3 months ago. Feb 09, 2017 - 15:18 PST
Investigating
We are currently investigating reports of a small portion of customers experiencing mail delays. We will provide more updates and information as it becomes available. Please visit status.sendgrid.com to subscribe to updates.
Posted 3 months ago. Feb 09, 2017 - 13:40 PST
This incident affected: Mail Sending (API v3, SMTP, API v2) and Marketing Campaigns (Marketing Campaigns, Legacy Newsletter).