Service Disruption: Site, API and Mail Availability
Incident Report for SendGrid
Resolved
We have confirmed that all mail has been dequeued and traffic is flowing again without issue. We apologize for any inconvenience this may have caused, and thank you so much for your patience. Please reach out to our support team with any additional questions: https://support.sendgrid.com.
Posted 14 days ago. Sep 06, 2017 - 16:55 PDT
Update
We have successfully dequeued the mail from one of our data centers and will continue to monitor the progress of the second data center's queue. Please let us know if you have any additional questions by reaching out via https://support.sendgrid.com
Posted 14 days ago. Sep 06, 2017 - 16:00 PDT
Update
We are keeping an eye on system behavior as mail queues continue to drain. We will provide an update when the queues have cleared. Thank you for your patience.
Posted 14 days ago. Sep 06, 2017 - 15:30 PDT
Monitoring
Site, mail send, webhook and API availability have been restored, as well as access to our Marketing Campaigns and Legacy Newsletter tool. We're accepting traffic and mail is dequeueing at this time. We're continuing to monitor performance and will provide another update shortly. We apologize for the inconvenience this may have caused and thank you for your patience. Please reach out to our Support Team at https://support.sendgrid.com with any questions.
Posted 14 days ago. Sep 06, 2017 - 14:52 PDT
Update
Additional systems impacted include Marketing Campaigns, our Legacy Newsletter tool and our webhooks. We're continuing to troubleshoot with the highest priority. Updates to follow.
Posted 14 days ago. Sep 06, 2017 - 14:16 PDT
Investigating
Our Ops team is currently investigating reports of login issues, email delays, and API timeouts. We are investigating this with the highest priority. We will provide more updates as they become available. Please reach out to support@sendgrid.com with any questions.
Posted 14 days ago. Sep 06, 2017 - 13:50 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2), Marketing Campaigns (Marketing Campaigns, Legacy Newsletter), Other Services (API), and Website.