Technical Incident: Mail Delay
Incident Report for SendGrid
Resolved
Our engineers have confirmed that mail has finally dequeued. You should no longer be seeing mail delays. We sincerely apologize for the inconvenience and thank you for your patience. Please reach out to our Support team at https://support.sendgrid.com if you have any questions.
Posted 3 months ago. May 05, 2018 - 00:04 PDT
Monitoring
Our engineers have made adjustments to help optimize mail flow. We will continue to monitor progress as mail dequeues. We apologize for the inconvenience and thank you for your patience. If you have any questions, please reach out to our Support team at https://support.sendgrid.com.
Posted 3 months ago. May 04, 2018 - 12:02 PDT
Investigating
A subset of our customers may be experiencing some delayed mail. Our Operations team is investigating the root cause. We'll provide updates here as we have them. We apologize for any inconvenience this is causing you. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted 3 months ago. May 04, 2018 - 09:58 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).