Technical Incident: Delayed Mail
Incident Report for SendGrid
Resolved
After closely monitoring mail flow, we have determined that the current technical incident is now resolved. Messages that were previously delayed have been processed. We sincerely apologize and thank you for your patience. Please contact our support team if you have any questions: https://support.sendgrid.com.
Posted 10 months ago. Mar 04, 2017 - 21:10 PST
Monitoring
We have identified the root cause of the mail delays. You may still see some short delays, but mail flow has resumed. We will continue to monitor mail flow to ensure the interruption is resolved. We thank you for your patience and will provide a final update. Please visit status.sendgrid.com to subscribe to future status posts.
Posted 10 months ago. Mar 04, 2017 - 19:53 PST
Update
Our operations and engineering teams are continuing to troubleshoot to find the core cause of these delays. Thank you so much for your patience as we get to the bottom of this. Please reach out to our support team at https://support.sendgrid.com with any additional questions.
Posted 10 months ago. Mar 04, 2017 - 19:23 PST
Investigating
We are currently investigating reports of delayed delivery of mail. Mail is currently being accepted and queued, we are working to resolve delivery and will update as we have more information.
Posted 10 months ago. Mar 04, 2017 - 18:19 PST
This incident affected: Mail Sending (API v3, SMTP, API v2).