Website Login Down
Incident Report for SendGrid
Resolved
After monitoring site logins over the last few hours we are considering this issue resolved. We apologize for the inconvenience this may have caused.
Posted Nov 20, 2015 - 08:30 PST
Monitoring
The login functionality has been restored and we are continuing to monitor website performance at the moment.
Posted Nov 20, 2015 - 05:27 PST
Identified
Our operations team has identified the cause of the issue and it's currently working to repair it.
Posted Nov 20, 2015 - 05:22 PST
Investigating
We're are currently seeing issues with the sendgrid.com website login page. We'll post more information here as we receive it.
Posted Nov 20, 2015 - 04:33 PST