Technical Incident: Paid Sign Ups and Upgrades Issue
Incident Report for SendGrid
Resolved
We've monitored the restored services and are confident paid sign ups and upgrades are fully operational. If you were unable to upgrade or have created a free account during this downtime, you will now be able to upgrade to the paid plan of your choice. We apologize for any inconvenience this caused. Please reach out to Support https://support.sendgrid.com with any questions.
Posted 3 months ago. Jul 20, 2017 - 15:16 PDT
Monitoring
Our paid sign ups and upgrades have been restored. If you were unable to upgrade or have created a free account during this downtime, you will now be able to upgrade to the paid plan of your choice. If you have any additional questions please reach out to our Support team at https://support.sendgrid.com. Thank you for your patience.
Posted 3 months ago. Jul 20, 2017 - 14:30 PDT
Investigating
Paid sign ups and upgrades are currently unavailable. Our team is working diligently to restore paid sign ups. In the meantime please sign up for a free account and upgrade once this issue is resolved. We apologize for any inconvenience. Please reach out to our Support team at https://support.sendgrid.com with any questions at this time.
Posted 3 months ago. Jul 20, 2017 - 13:58 PDT
This incident affected: Website.