Whitelabel Domain - intermittent validation issue
Incident Report for SendGrid
Resolved
A fix has been deployed, and users should be able to validate domain whitelabels again. If you have any questions, please reach out to our support team at support.sendgrid.com.
Posted Feb 19, 2016 - 15:40 PST
Identified
We've identified the root cause of this issue, and are working with our provider to mitigate & correct it.

Currently, our recommended workaround is to try again. If you're continuing to experience a timeout when attempting to validate, please disable the "automatic security" feature on the Whitelabel. This will require you to update the records that are built for the Whitelabel, but will not timeout. We understand that this is not a fully-feature workaround, and apologize for the inconvenience.
Posted Jan 04, 2016 - 15:02 PST
Investigating
Customers may see a "Sorry, some unexpected error occurred" message appearing when attempting to validate a new whitelabel. Our engineers are currently working on a fix, keep in mind that you're still able to send email without validating your whitelabel. We apologize for any inconvenience, please direct any questions to our support team. - PB
Posted Dec 23, 2015 - 08:00 PST