Gmail delivery issues
Incident Report for SendGrid
Resolved
Gmail issues are now resolved: https://www.google.com/appsstatus#hl=en&v=issue&sid=1&iid=25ed42fe3d6cc7b1b1a98320fd9e0bf1
Affected messages will also be delivered after a short delay. No messages were lost through the issue.
Posted about 1 month ago. Mar 09, 2017 - 23:12 PST
Investigating
Gmail is currently having issues, expect delays when sending to Gmail addresses. They are receiving&queueing the emails. Gmail is investigating the issue. The Google apps status page can be viewed here: https://www.google.com/appsstatus#hl=en&v=status
Posted about 1 month ago. Mar 09, 2017 - 22:25 PST