General Availability of SendGrid’s New Customer Portal
Incident Report for SendGrid
Resolved
This incident has been resolved.
Posted Aug 07, 2015 - 14:28 PDT
Monitoring
We are happy to announce the general availability of SendGrid’s new Customer Portal!
With today’s launch, we’ve reinvented the way that our customers interact with SendGrid. Whether it be through our innovative and seamless interface, or our new, robust Web API, our customers will experience the new SendGrid Customer Portal as the most intuitive and flexible way to engage with their customers through email.

In full, the new Customer Portal includes:
- New and improved UX and UI
- Introducing Web API v3, that standardizes return data patterns, response codes, and endpoint names. This is available on a limited set of endpoints at this time, which will be growing in the coming weeks and months.
- Overhauled whitelabel management including:
- Decoupled link whitelabel, IP whitelabel, and domain whitelabel to allow for more flexibility
- Domain whitelabeling with Automated Security to eliminate domain spoofing attempts
- Subuser impersonation allowing customers to move seamlessly from parent to subuser account
- Streamlined subuser creation and management making it easier to create and manage subuser accounts and IPs
- Advanced Suppression Manager enabling suppression list management and an email preference center for recipients
- Enhanced alert settings to improve account stats and usage notifications
- Updated advanced statistics with unlimited timeframe and searchable categories
- Enhanced mail settings to customize outbound mail presentation, whitelists, event notifications, and more
- Updated account sign-up/billing/upgrades/downgrades/cancellation
- Inbound Parse- Enables consumption and inspection of specific parsed elements
Posted Jul 07, 2015 - 08:44 PDT