Technical Incident: Marketing Campaigns returns empty contact page
Incident Report for SendGrid
Resolved
Marketing Campaigns contacts and sending has been fully restored to all customers at the expected performance level you can trust from our service.

Our team is working with a handful of customers who need additional, account-specific resolution related to their contacts and campaign sends. We are communicating individually with these customers and will update them directly moving forward. We sincerely thank you for your patience. Please reach out to our Support team with any questions at https://support.sendgrid.com.
Posted 6 months ago. Jan 15, 2018 - 23:12 PST
Identified
Our engineers have identified the issue and are working towards a resolution. Campaign sends and contact additions & edits are still suspended for a subset of customers. We will provide more information as it becomes available. We apologize for the inconvenience and thank you for your patience. Please contact our Support team with any questions: https://support.sendgrid.com/
Posted 6 months ago. Jan 15, 2018 - 20:00 PST
Update
Our engineering team has suspended campaign sending and contact interactions for a subset of customers while we continue to investigate. Thank you for your patience. Please contact our support team with any questions: https://support.sendgrid.com/
Posted 6 months ago. Jan 15, 2018 - 17:29 PST
Investigating
A small subset of Marketing Campaigns customers may see empty list and segment pages or campaigns marked "sent" but mail has not actually sent. Our team is currently investigating. Thank you for your patience. Please contact our support team with any questions: https://support.sendgrid.com/
Posted 6 months ago. Jan 15, 2018 - 15:47 PST
This incident affected: Marketing Campaigns (Marketing Campaigns).