Service Disruption: Mail and Authentication Delays
Incident Report for SendGrid
Resolved
Our Operations team implemented a fix that has resolved this issue. Any mail delayed due to this incident has been sent. We’ve mitigated slowness authenticating, loading app.sendgrid.com and Marketing Campaigns. We apologize for any inconvenience this caused you. Please contact our Support team with any questions: https://support.sendgrid.com/
Posted 30 days ago. Dec 22, 2018 - 00:51 PST
Investigating
A small subset of customers may report some email delays, slowness authenticating, loading app.sendgrid.com and Marketing Campaigns. Our operations team is working towards a resolution. We apologize for any inconvenience has caused. Please contact our support team with questions: https://support.sendgrid.com/
Posted about 1 month ago. Dec 21, 2018 - 18:25 PST
This incident affected: Mail Sending (API v3, SMTP, API v2), Marketing Campaigns (Marketing Campaigns), and Website.