Technical Incident: Paid Signup and Upgrade issues
Incident Report for SendGrid
Resolved
The issue with our payment gateway has been resolved. Account upgrades, credit card updates and paid signups are restored. If you encountered an error when trying to upgrade, add, or update payment information, please try again now. Thank you for your patience and please reach out to our Support Team at https://support.sendgrid.com/ with any questions. ab
Posted 5 months ago. May 26, 2017 - 05:54 PDT
Investigating
Our payment gateway is currently experiencing issues. Users attempting to sign up for paid accounts, upgrade their accounts or update their credit card may encounter errors. We apologize for the inconvenience. More updates to follow. ab
Posted 5 months ago. May 26, 2017 - 04:59 PDT