Service Disruption - Mail Send, API Call & UI Load Issues
Incident Report for SendGrid
Resolved
Our Operations team has verified that Mail Send, API and UI Loads are now working as expected for customers in the European region. We greatly appreciate your patience through this process and apologize for any inconvenience this may have caused. If you have any questions, you can reach out to our Support team at https://support.sendgrid.com.
Posted about 1 month ago. Mar 20, 2019 - 09:38 PDT
Update
After monitoring, the Operations team has verified that Mail Send, API and UI Loads are now working as expected for customers in the European region. We greatly appreciate your patience through this process and apologize for any inconvenience this may have caused. If you have any questions, you can reach out to our Support team at https://support.sendgrid.com.
Posted about 1 month ago. Mar 20, 2019 - 08:32 PDT
Monitoring
Our engineers have implemented a fix and we are currently monitoring the situation. We apologize for any inconvenience this may have caused. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted about 1 month ago. Mar 20, 2019 - 06:27 PDT
Investigating
Around 5:30AM MDT we began receiving reports from customers experiencing latency and errors with mailsend, API and when loading the UI. These issues seem to be isolated to customers within the European region. Our Operations team is investigating the situation and working towards a resolution. We apologize for any inconvenience this may cause. If you have questions, please contact our Support team at https://support.sendgrid.com/.
Posted about 1 month ago. Mar 20, 2019 - 06:16 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2), Marketing Campaigns (Marketing Campaigns), Other Services (API), and Website.