Mail Delivery Delays
Incident Report for SendGrid
Resolved
After monitoring system performance we have verified this issue is resolved. We apologize for any inconvenience this caused and appreciate your patience. Please reach out to our Support team at https://support.sendgrid.com if you have any questions.
Posted Feb 19, 2020 - 19:11 PST
Monitoring
We have confirmed the subset of delayed mail has fully dequeued. We’re currently monitoring system performance. We apologize for any inconvenience this may have caused. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted Feb 19, 2020 - 18:42 PST
Identified
We've confirmed that new mail received is being processed and delivery is attempted as normal. We are currently working to dequeue the subset of mail that was delayed between approximately 4:30 pm MT and 5:00 pm MT. We will continue to update as that mail dequeues.
Posted Feb 19, 2020 - 17:26 PST
Investigating
We're currently investigating reports of mail delivery delays impacting users, beginning at approximately 4:30 pm MT. We will update as soon as we have further details of the scope and impact.
Posted Feb 19, 2020 - 17:05 PST
This incident affected: Mail Sending (API v3, SMTP, API v2).