Users are encountering a 'Something went wrong' error when attempting to log in.

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with log in attempts returning a “Something went wrong” error has been resolved. All services are now operating normally at this time.
Posted Jul 23, 2025 - 09:32 PDT

Monitoring

Our engineers have implemented a fix and are monitoring system performance. Users should now be able to log into accounts again. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 23, 2025 - 08:29 PDT

Investigating

Starting around 6:00 AM PST on July 23, our engineers began investigating an issue with the login experience for Unified users. Users may experience the error "Something went wrong" when attempting to log in. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 23, 2025 - 07:23 PDT
This incident affected: Website.