Intermittent Auth Failures to Mail Send Endpoints
Incident Report for SendGrid
Resolved
This incident has been resolved and the system functionality of our mailsend endpoints has been resolved.
Posted Nov 01, 2022 - 12:38 PDT
Update
We are continuing to monitor the impact of this issue. We will provide another update as soon as possible.
Posted Nov 01, 2022 - 11:36 PDT
Monitoring
Our engineers have mitigated the issue, and are continuing to monitor. Affected customers may see that mailsend calls between 2am-10am PT resulted in 503 errors. We will provide another update as soon as more information becomes available.
Posted Nov 01, 2022 - 10:35 PDT
Investigating
Beginning at 9:00 AM PT, our engineering team began investigating an issue with intermittent auth errors. At this time, customers may see 503 errors when communicating with mailsend endpoints. We will provide another update within an hour or sooner if more information becomes available.
Posted Nov 01, 2022 - 10:11 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).