Service Disruption: New Account Signups
Incident Report for SendGrid
Resolved
The issue with new account signups has been resolved. If you attempted to sign up during this time and did not receive a confirmation, please visit https://sendgrid.com and attempt to log in with the credentials you initially created to complete your account profile. We greatly appreciate your patience and apologize for any inconvenience this may have caused. Please contact our Support team with any questions: https://support.sendgrid.com/.
Posted 4 months ago. Apr 18, 2019 - 15:15 PDT
Monitoring
Our team has identified the source of the issue and implemented a fix. We are seeing that new customer signup attempts were successful during this time, however the confirmation page did not appear. If you attempted to sign up and did not receive a confirmation, please visit https://sendgrid.com and attempt to log in with the credentials you initially created to complete your account profile. We are continuing to monitor the situation and will provide an update when we confirm the issue has been resolved. We appreciate your patience and apologize for any inconvenience this may be causing. Please contact our Support team with any questions: https://support.sendgrid.com/.
Posted 4 months ago. Apr 18, 2019 - 14:28 PDT
Investigating
We are currently investigating issues with free and paid new account signups. We will provide an update as more information becomes available. We appreciate your patience and apologize for any inconvenience this may be causing. Please contact our Support team with any questions: https://support.sendgrid.com/.
Posted 4 months ago. Apr 18, 2019 - 12:45 PDT
This incident affected: Website.