Service Disruption: Paid Account Signups
Incident Report for SendGrid
Resolved
We have verified the third party provider has resolved the issue and sign up is available once again. If you attempted sign up during this time and incorrectly received a Trial account you may upgrade to your desired plan now. We thank you for your patience and apologize for any inconvenience this may have caused. Please reach out to our Support team if you have any questions at https://support.sendgrid.com/.
Posted 4 months ago. Apr 25, 2019 - 10:24 PDT
Investigating
One of our third party billing providers is experiencing an issue causing paid signups to be unavailable on our platform. We will provide an update as more information becomes available. We appreciate your patience and apologize for any inconvenience this may be causing. Please contact our Support team with any questions: https://support.sendgrid.com/.
Posted 4 months ago. Apr 25, 2019 - 09:57 PDT
This incident affected: Website.