Technical Incident: Legacy Marketing Campaigns Site Latency and Errors
Incident Report for SendGrid
Resolved
After monitoring the fix, we have verified that the issues surrounding site slowness and errors with Legacy Marketing Campaigns have been resolved. We apologize for any inconvenience this may have caused and appreciate your patience. Please reach out to our Support team at https://support.sendgrid.com if you have any questions.
Posted Nov 06, 2019 - 10:36 PST
Monitoring
Our engineers have implemented a fix and we are currently monitoring performance. We apologize for any inconvenience this may have caused. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted Nov 06, 2019 - 09:27 PST
Investigating
Our Operations team is currently investigating reports of customers intermittently experiencing site slowness or errors when navigating through Legacy Marketing Campaigns. Mail send is not affected by this issue. We will provide additional updates as they become available and greatly appreciate your patience through this process. Please contact our Support team with any questions: https://support.sendgrid.com/
Posted Nov 06, 2019 - 08:36 PST
This incident affected: Marketing Campaigns (Marketing Campaigns) and Website.