Technical Incident: Website Slowness and Errors
Incident Report for SendGrid
Resolved
Our Operations team has verified the fix is working as expected. Our systems are now fully operational. Again, we apologize for the inconvenience this has caused. If you have any questions, please reach out to our Support team at https://support.sendgrid.com.
Posted 26 days ago. Sep 18, 2019 - 15:27 PDT
Monitoring
Our engineers have implemented a fix and we are currently monitoring performance. We apologize for any inconvenience this may have caused. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted 26 days ago. Sep 18, 2019 - 15:05 PDT
Investigating
Our Operations team is currently investigating reports of site slowness and a number of errors within the UI. We are investigating this with the highest priority and will provide more updates as they become available. We apologize for the inconvenience this is causing. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted 26 days ago. Sep 18, 2019 - 14:20 PDT
This incident affected: Website.