Service Disruption: Third Party Billing Provider Down
Incident Report for SendGrid
Resolved
The third party has fixed the issue and billing is now working as expected. Once again we apologize for any inconvenience this may cause and greatly appreciate your patience. Please reach out to our Support team with any questions at https://support.sendgrid.com/
Posted Nov 24, 2019 - 02:59 PST
Monitoring
Due to a third party provider, our billing system is down. You may experience difficulties with signing up for a paid account, upgrading to a paid account, or viewing/updating any billing related information. We apologize for any inconvenience this may cause and greatly appreciate your patience. Please reach out to our Support team with any questions at https://support.sendgrid.com/
Posted Nov 23, 2019 - 23:28 PST
This incident affected: Website.