Incident - New Marketing Campaigns Contact Uploading and Campaign Sends
Incident Report for SendGrid
Resolved
After monitoring the fix, we have verified that it is working as expected and there is no longer a delay for contacts that were uploaded or modified in New Marketing Campaigns during the window of 9am-6pm MT. Thank you very much for your patience, we apologize for the inconvenience. Please reach out to our Support team at https://support.sendgrid.com if you have any questions.
Posted 27 days ago. Aug 26, 2019 - 20:42 PDT
Monitoring
We have processed the additional changes and implemented a fix. With this, all New Marketing Campaigns sends and contacts exports have been re-enabled. We are monitoring the performance of the fix. Please note, a small subset of customers may still be experiencing a delay in contacts that were uploaded or modified in the New Marketing Campaigns between about 9am MT and 6pm MT. We apologize for the inconvenience and greatly appreciate your patience. Please reach out to our Support team at https://support.sendgrid.com if you have any questions.
Posted 27 days ago. Aug 26, 2019 - 17:58 PDT
Identified
While monitoring the fix, engineers have identified additional work to fully resolve this issue. As a result, New Marketing Campaigns sends and contacts exports have been temporarily disabled to allow for a full resolution to be implemented. We apologize for any inconvenience this may be causing you. Please reach out to our Support team at https://support.sendgrid.com if you have any questions.
Posted 27 days ago. Aug 26, 2019 - 14:27 PDT
Update
We are continuing to monitor the issue. The fix has been implemented, however we are seeing resolutions taking some time to fully process. We thank you for your patience in this. Please reach out to our Support team at https://support.sendgrid.com if you have any questions.
Posted 27 days ago. Aug 26, 2019 - 13:32 PDT
Monitoring
A fix has been implemented and we are seeing improvements to the system as a result. We will continue to monitor the situation. We apologize for any inconvenience this may have caused and appreciate your patience. Please reach out to our Support team at https://support.sendgrid.com if you have any questions.
Posted 27 days ago. Aug 26, 2019 - 11:53 PDT
Identified
We have located the cause of this issue and are working on implementing a fix. We apologize for any inconvenience this may have caused and appreciate your patience. Please reach out to our Support team at https://support.sendgrid.com if you have any questions.
Posted 27 days ago. Aug 26, 2019 - 10:29 PDT
Investigating
We are currently investigating an issue regarding recently uploaded contacts to the New Marketing Campaigns, impacting CSV exports and campaign sending. Starting around 8:50am MT, customers may experience a delay in exporting CSVs or notice that campaigns being sent are missing recently uploaded contacts. Legacy Marketing Campaigns contact operations are not affected. We will provide additional updates as they become available and greatly appreciate your patience through this process. Please contact our support team with any questions: https://support.sendgrid.com/.
Posted 27 days ago. Aug 26, 2019 - 09:04 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns).