Technical Incident: Marketing Campaigns Signup Forms Not Loading
Incident Report for SendGrid
Resolved
After monitoring the fix, we have verified that the issues has been resolved. We apologize for any inconvenience this may have caused and appreciate your patience. Please reach out to our Support team at https://support.sendgrid.com if you have any questions.
Posted Nov 11, 2019 - 09:23 PST
Monitoring
Our engineers have implemented a fix and we are currently monitoring performance. We apologize for any inconvenience this may have caused. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted Nov 11, 2019 - 09:13 PST
Investigating
We are currently looking into issues with our Marketing Campaigns Signup Forms not loading. We will provide additional updates as they become available and greatly appreciate your patience through this process. Please contact our Support team with any questions: https://support.sendgrid.com/
Posted Nov 11, 2019 - 08:35 PST
This incident affected: Marketing Campaigns (Marketing Campaigns).