Technical Incident: Mail Delays
Incident Report for SendGrid
Resolved
We have monitored and verified that mail and stats are no longer delayed. We sincerely apologize for the inconvenience and thank you for your patience. If you have any questions, please contact our Support team at https://support.sendgrid.com/
Posted 4 days ago. Oct 10, 2019 - 14:10 PDT
Identified
We have identified and implemented a fix for the issue affecting mail delays. We are continuing our investigation for a possible delay in associated stats. We apologize for the inconvenience and thank you for your patience as we work toward a resolution. Please contact our Support team with any questions at https://support.sendgrid.com/
Posted 4 days ago. Oct 10, 2019 - 13:17 PDT
Investigating
Starting around 12PM MT, a network issue may be causing mail delays for a subset of customers. Our team is currently investigating and working toward mitigation of the issue. We will provide updates as they become available. Please contact our Support team with any questions at https://support.sendgrid.com/
Posted 4 days ago. Oct 10, 2019 - 11:23 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).