Unable to add new IP Address
Incident Report for SendGrid
Resolved
Our engineers have been monitoring the fix and have confirmed that the problem with adding new IP addresses has been resolved. All services are now operating normally at this time.
Posted Oct 07, 2022 - 07:02 PDT
Monitoring
A fix has been implemented by the third-party provider and the customers are now able to add new dedicated IPs from the user interface. Our team will continue to monitor the performance of our systems. We will provide an update within an hour or sooner if more information is available.
Posted Oct 07, 2022 - 06:23 PDT
Update
The third-party issue is still ongoing. Impact has not changed. We apologize for the inconvenience. We will provide another update as soon as more information becomes available.
Posted Oct 07, 2022 - 03:54 PDT
Update
The third-party problem is still present. The current impact continues to affect attempts to add an IP from the user interface. As a workaround, customers can add IPs via API: https://docs.sendgrid.com/api-reference/ip-address/add-ips. We will provide another update in two hours, or as soon as more information becomes available.
Posted Oct 07, 2022 - 01:53 PDT
Identified
On October 6th, around 11:00 PM PST, our engineering team identified an issue with adding new dedicated IPs. It appears to be the result of a problem on a third-party provider side. When attempting to add a new dedicated IP from UI, customers would see a message stating that "We're sorry, we were unable to add the new IP address. Please try again.". This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 07, 2022 - 00:26 PDT
This incident affected: API.