Unable to download invoices through the UI
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and customers should now be able to download invoices within the UI.
Posted Apr 26, 2022 - 11:12 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. Customers may still see an error when attempting to download an invoice. Refreshing the page should trigger the invoice to download. We will provide another update within an hour or as more information becomes available. Please contact our Support Team if invoice downloads continue to fail.
Posted Apr 26, 2022 - 09:57 PDT
Update
Our engineers are continuing to work towards a fix for the issue preventing customers from downloading invoices. We will provide another update within 8 hours or as soon as more information becomes available.
Posted Apr 26, 2022 - 07:16 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 25, 2022 - 17:28 PDT
Identified
Our engineers have identified the issue and are working toward a possible fix. We will provide another update in one hour or as soon as more information becomes available.
Posted Apr 25, 2022 - 16:38 PDT
Investigating
Starting around 11:30PST on 04-25-21, our engineers began investigating an issue where customers are unable to download invoices through our User Interface. This does not impact mail send. We will provide another update in one hour or as soon as more information becomes available.
Posted Apr 25, 2022 - 15:47 PDT
This incident affected: Website.