Service Disruption - Latency and Connection Timeouts for SendGrid SMTP/API and Site
Incident Report for SendGrid
Resolved
Our engineers have monitored our system and confirmed the third party incident is resolved. We greatly appreciate your patience and apologize for any inconvenience this may have caused. Please contact our Support team with any questions: https://support.sendgrid.com/.
Posted Jun 09, 2020 - 21:35 PDT
Monitoring
Our third party provider reports their incident is resolved. We are monitoring our systems and will provide an update when we confirm the issue has been resolved. We appreciate your patience and apologize for any inconvenience this may be causing. Please contact our Support team with any questions: https://support.sendgrid.com/.
Posted Jun 09, 2020 - 20:57 PDT
Identified
Our engineers have implemented a workaround to help mitigate the issue for our customers while our third party provider works toward a resolution. Customers within the USA should be seeing an improvement in latency and connection timeouts. International customers may still be experiencing higher latency for SMTP/API calls and sendgrid.com site. We will continue monitoring the situation and provide updates. We apologize for any inconvenience this may cause. If you have any questions, please contact our Support team at https://support.sendgrid.com/
Posted Jun 09, 2020 - 16:35 PDT
Investigating
Due to a third party incident, customers may be experiencing higher latency or connection timeouts for API calls and sendgrid.com site. This includes both SMTP and API mail send. We are currently monitoring the situation and will provide updates as we learn more. We apologize for any inconvenience this may cause. If you have any questions, please contact our Support team at https://support.sendgrid.com/
Posted Jun 09, 2020 - 15:54 PDT
This incident affected: Other Services (API), Marketing Campaigns (Marketing Campaigns), Mail Sending (API v3, SMTP, API v2), and Website.