Mail Delayed 9/18/20 9:10 PM MT
Incident Report for SendGrid
Resolved
After monitoring, we can confirm that systems have returned to normal. We sincerely apologize for any inconvenience this issue may have caused and greatly appreciate your patience.
Posted Sep 18, 2020 - 22:12 PDT
Monitoring
Delayed mail impacted by this disruption has been sent and mail flow appears to have returned to normal levels. We are continuing to monitor the system and apologize for any inconvenience this may have caused.
Posted Sep 18, 2020 - 21:38 PDT
Investigating
At around 9:10 PM MT, we noticed mail delays for a subset of our customers due to a third party incident. The mail affected by this issue is being placed in a separate queue for now. We sincerely apologize for any inconvenience this may cause and will provide updates as they become available.
Posted Sep 18, 2020 - 20:57 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).