Errors When Upgrading/Downgrading and Making Changes within the SendGrid UI
Incident Report for SendGrid
Resolved
Our team has monitored the fix and confirmed the issue causing errors within the UI has been resolved. All services are now operating as expected.
Posted Jun 14, 2022 - 13:32 PDT
Monitoring
Our team has implemented a fix and we are monitoring system performance. We will provide another update within 30 minutes.
Posted Jun 14, 2022 - 12:47 PDT
Update
We are continuing to work towards a fix for this issue. We will provide another update within two hours or sooner if more information becomes available.
Posted Jun 14, 2022 - 12:26 PDT
Update
Our engineers are continuing to work towards a fix for this issue. We will provide another update within an hour or sooner if more information becomes available.
Posted Jun 14, 2022 - 11:34 PDT
Update
Our engineers are continuing to work towards a fix for this issue. We will provide another update within an hour or sooner if more information becomes available.
Posted Jun 14, 2022 - 10:29 PDT
Identified
Our engineers have identified the cause of this issue and are working towards a fix with a third-party provider. We will provide an update within an hour or sooner if more information becomes available.
Posted Jun 14, 2022 - 09:28 PDT
Investigating
Starting around 8:21 AM PT, our engineers began investigating issues with making account changes within the SendGrid console. At this time, customers may experience errors when attempting to upgrade/downgrade the account, making changes to account details, and general errors within the SendGrid console. This does not impact mail send or stats. We will provide another update within the next hour or as soon as more information becomes available.
Posted Jun 14, 2022 - 08:55 PDT
This incident affected: Website.